Update collectd to version 5.9.0 * remove backported upstream patches (sensors, modbus) * remove lua patch that has been been implemented upstream (See collectd PR 3144) * refresh patches and accommodate into upstream path changes * place the 'stations' datatype for iwinfo in alpbetically correct place in types.db * add libmnl dependency to 'processes' plugin required for the new Linux process Delay Accounting capability. (Alternatively the capability & requirement might be patched away in Makefile.am, HAVE_LIBTASKSTATS from collectd_4ea7a572) * new plugins (disabled): ampq1, gpu_nvidia, pcie_errors, write_stackdriver, write_syslog compile-tested: ar71xx/WNDR3700 (all plugins) run-tested: ar71xx/WNDR3700 (selected plugins) Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
11 lines
345 B
Diff
11 lines
345 B
Diff
--- a/src/daemon/plugin.c
|
|
+++ b/src/daemon/plugin.c
|
|
@@ -1085,7 +1085,7 @@ static int plugin_insert_read(read_func_
|
|
int status;
|
|
llentry_t *le;
|
|
|
|
- rf->rf_next_read = cdtime();
|
|
+ rf->rf_next_read = cdtime() + (cdtime_t) 1073741824; //delay first read 1s
|
|
rf->rf_effective_interval = rf->rf_interval;
|
|
|
|
pthread_mutex_lock(&read_lock);
|