removed some sources to download perl. I believe I only need one source to download perl at https://www.cpan.org/src/5.0. I see some Linux distributions use that source to download. change the position of PKG_MAINTAINER to make it neater and prettier perform a patch refresh removes some patches that have been applied in perl-5.38.0 as well as patches that are no longer used in perl-5.38.0 added one patch Perl/perl5@ba6e2c3 this fixes the issue regcomp*.c, regexec.c - fixup regex engine build under -Uusedl provided updates and synchronized libc.config base.config version.config to perl-5.38.0 removed deprecated arybase in perl-5.29.4 Signed-off-by: Andy Syam <privasisource@gmail.com>
38 lines
2.1 KiB
Diff
38 lines
2.1 KiB
Diff
--- a/Makefile.SH
|
|
+++ b/Makefile.SH
|
|
@@ -346,7 +346,7 @@ OBJ_EXT = $_o
|
|
# Macros to invoke a copy of miniperl during the build. Targets which
|
|
# are built using these macros should depend on \$(MINIPERL_EXE)
|
|
MINIPERL_EXE = miniperl\$(EXE_EXT)
|
|
-MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE_EXT) -Ilib
|
|
+MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE_EXT) -Ilib -I.
|
|
|
|
# Macros to invoke sort the MANIFEST during build
|
|
MANIFEST_SRT = MANIFEST.srt
|
|
@@ -996,7 +996,7 @@ lib/buildcustomize.pl: $& $(miniperl_obj
|
|
@$(RMS) miniperl.xok
|
|
$(CC) $(CLDFLAGS) $(NAMESPACEFLAGS) -o $(MINIPERL_EXE) \
|
|
$(miniperl_objs) $(libs)
|
|
- $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
+ $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -I. -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
$(MINIPERL) -f write_buildcustomize.pl
|
|
!NO!SUBS!
|
|
;;
|
|
@@ -1007,7 +1007,7 @@ lib/buildcustomize.pl: \$& \$(miniperl_d
|
|
@\$(RMS) miniperl.xok
|
|
@\$(RMS) \$(MINIPERL_EXE)
|
|
\$(LNS) \$(HOST_PERL) \$(MINIPERL_EXE)
|
|
- \$(LDLIBPTH) ./miniperl\$(HOST_EXE_EXT) -w -Ilib -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
+ \$(LDLIBPTH) ./miniperl\$(HOST_EXE_EXT) -w -Ilib -I. -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
\$(MINIPERL) -f write_buildcustomize.pl 'osname' "$osname"
|
|
!GROK!THIS!
|
|
else
|
|
@@ -1016,7 +1016,7 @@ lib/buildcustomize.pl: $& $(miniperl_dep
|
|
@$(RMS) miniperl.xok
|
|
$(CC) $(CLDFLAGS) -o $(MINIPERL_EXE) \
|
|
$(miniperl_objs) $(libs)
|
|
- $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
+ $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -I. -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
$(MINIPERL) -f write_buildcustomize.pl
|
|
!NO!SUBS!
|
|
fi
|