packages/utils/openzwave/patches/902_no-udev.patch
Stijn Tintel 14f01cb946 openzwave: new package
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
2017-03-03 01:56:21 +01:00

24 lines
551 B
Diff

--- a/cpp/src/platform/unix/SerialControllerImpl.cpp
+++ b/cpp/src/platform/unix/SerialControllerImpl.cpp
@@ -34,10 +34,6 @@
#include "SerialControllerImpl.h"
#include "platform/Log.h"
-#ifdef __linux__
-#include <libudev.h>
-#endif
-
using namespace OpenZWave;
//-----------------------------------------------------------------------------
--- a/cpp/build/Makefile
+++ b/cpp/build/Makefile
@@ -59,7 +59,7 @@ endif
else
LDFLAGS += -shared -Wl,-soname,libopenzwave.so.$(VERSION)
-LIBS += -ludev
+LIBS +=
endif
CFLAGS += $(CPPFLAGS)