packages/net/irssi/patches/010-Fix-finding-OpenSSL-when-1.1-with-deprecated-APIs-di.patch
Ilya Lipnitskiy b1cbd93bcd
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset:

  find -L package/feeds/packages/ -name patches | \
  sed 's/patches$/refresh/' | sort | xargs make

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
(cherry picked from commit 5d8d4fbbcb)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2021-02-25 01:26:05 +08:00

22 lines
739 B
Diff

From cff1385b398b59c74c535d6c0cd9deec561101fd Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Fri, 15 Feb 2019 15:02:34 -0800
Subject: [PATCH] Fix finding OpenSSL when 1.1 with deprecated APIs disabled
SSL_library_init is a deprecated function. OPENSSL_init_ssl is not in 1.0.2.
SSL_CTX_new is in both.
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/configure.ac
+++ b/configure.ac
@@ -328,7 +328,7 @@ PKG_CHECK_MODULES([OPENSSL], [openssl],
CFLAGS="$CFLAGS $OPENSSL_CFLAGS"
LIBS="$LIBS $OPENSSL_LIBS"
], [
- AC_CHECK_LIB([ssl], [SSL_library_init], [
+ AC_CHECK_LIB([ssl], [SSL_CTX_new], [
LIBS="$LIBS -lssl -lcrypto"
], [
AC_MSG_ERROR([The OpenSSL library was not found])