The libintl check is broken in meson.build. Patched it and added back the gettext build dependencies. Avoids the proxy-intl thing that glib2 likes to use. Updated configure options. Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
406 B
Diff
11 lines
406 B
Diff
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1955,7 +1955,7 @@ endif
|
|
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
|
|
# implementations. This could be extended if issues are found in some platforms.
|
|
libintl_deps = []
|
|
-if cc.has_function('ngettext')
|
|
+if false
|
|
have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
|
|
else
|
|
# First just find the bare library.
|