Update vsftpd to 3.0.3 released in July 2015. Changelog: https://security.appspot.com/vsftpd/Changelog.txt Release blog: http://scarybeastsecurity.blogspot.fi/2015/07/vsftpd-303-released-and-horrors-of-ftp.html - Increase VSFTP_AS_LIMIT to 200MB; various reports. - Make the PWD response more RFC compliant; report from Barry Kelly <barry@modeltwozero.com>. - Remove the trailing period from EPSV response to work around BT Internet issues; report from Tim Bishop <tdb@mirrorservice.org>. - Fix syslog_enable issues vs. seccomp filtering. Report from Michal Vyskocil <mvyskocil@suse.cz>. At least, syslogging seems to work on my Fedora now. - Allow gettimeofday() in the seccomp sandbox. I can't repro failures, but I probably have a different distro / libc / etc. and there are multiple reports. - Some kernels support PR_SET_NO_NEW_PRIVS but not PR_SET_SECCOMP, so handle this case gracefully. Report from Vasily Averin <vvs@odin.com>. - List the TLS1.2 cipher AES128-GCM-SHA256 as first preference by default. - Make some compile-time SSL defaults (such as correct client shutdown handling) stricter. - Disable Nagle algorithm during SSL data connection shutdown, to avoid 200ms delays. From Tim Kosse <tim.kosse@filezilla-project.org>. - Kill the FTP session if we see HTTP protocol commands, to avoid cross-protocol attacks. A report from Jann Horn <jann@thejh.net>. - Kill the FTP session if we see session re-use failure. A report from Tim Kosse <tim.kosse@filezilla-project.org>. (vsftpd-3.0.3pre1) - Enable ECDHE, Tim Kosse <tim.kosse@filezilla-project.org>. - Default cipher list is now just ECDHE-RSA-AES256-GCM-SHA384. - Minor SSL logging improvements. - Un-default tunable_strict_ssl_write_shutdown again. We still have tunable_strict_ssl_read_eof defaulted now, which is the important one to prove upload integrity. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
47 lines
1.6 KiB
Diff
47 lines
1.6 KiB
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -22,6 +22,8 @@ OBJS = main.o utility.o prelogin.o ftpcm
|
|
seccompsandbox.o
|
|
|
|
|
|
+DESTDIR =
|
|
+
|
|
.c.o:
|
|
$(CC) -c $*.c $(CFLAGS) $(IFLAGS)
|
|
|
|
@@ -29,21 +31,20 @@ vsftpd: $(OBJS)
|
|
$(CC) -o vsftpd $(OBJS) $(LINK) $(LDFLAGS) $(LIBS)
|
|
|
|
install:
|
|
- if [ -x /usr/local/sbin ]; then \
|
|
- $(INSTALL) -m 755 vsftpd /usr/local/sbin/vsftpd; \
|
|
- else \
|
|
- $(INSTALL) -m 755 vsftpd /usr/sbin/vsftpd; fi
|
|
- if [ -x /usr/local/man ]; then \
|
|
- $(INSTALL) -m 644 vsftpd.8 /usr/local/man/man8/vsftpd.8; \
|
|
- $(INSTALL) -m 644 vsftpd.conf.5 /usr/local/man/man5/vsftpd.conf.5; \
|
|
- elif [ -x /usr/share/man ]; then \
|
|
- $(INSTALL) -m 644 vsftpd.8 /usr/share/man/man8/vsftpd.8; \
|
|
- $(INSTALL) -m 644 vsftpd.conf.5 /usr/share/man/man5/vsftpd.conf.5; \
|
|
- else \
|
|
- $(INSTALL) -m 644 vsftpd.8 /usr/man/man8/vsftpd.8; \
|
|
- $(INSTALL) -m 644 vsftpd.conf.5 /usr/man/man5/vsftpd.conf.5; fi
|
|
- if [ -x /etc/xinetd.d ]; then \
|
|
- $(INSTALL) -m 644 xinetd.d/vsftpd /etc/xinetd.d/vsftpd; fi
|
|
+ mkdir -p $(DESTDIR)/usr/sbin
|
|
+ $(INSTALL) -m 755 vsftpd $(DESTDIR)/usr/sbin/
|
|
+ mkdir -p $(DESTDIR)/usr/share/man/man8
|
|
+ $(INSTALL) -m 644 vsftpd.8 $(DESTDIR)/usr/share/man/man8/
|
|
+ mkdir -p $(DESTDIR)/usr/share/man/man5
|
|
+ $(INSTALL) -m 644 vsftpd.conf.5 $(DESTDIR)/usr/share/man/man5/
|
|
+ mkdir -p $(DESTDIR)/etc/xinetd.d
|
|
+ $(INSTALL) -m 644 xinetd.d/vsftpd $(DESTDIR)/etc/xinetd.d/
|
|
+
|
|
+uninstall:
|
|
+ rm -f $(DESTDIR)/usr/sbin/vsftpd
|
|
+ rm -f $(DESTDIR)/usr/share/man/man8/vsftpd.8
|
|
+ rm -f $(DESTDIR)/usr/share/man/man5/vsftpd.conf.5
|
|
+ rm -f $(DESTDIR)/etc/xinetd.d/vsftpd
|
|
|
|
clean:
|
|
rm -f *.o *.swp vsftpd
|