packages/libs/librsocket-cpp/patches/103-no-boost-thread.patch
Rosen Penev 8ceee72c77
librsocket-cpp: Update to 2019-10-07
Added patch to remove boost-thread dependency.

Added size optimizations.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-10-07 10:59:59 -07:00

11 lines
427 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,7 +195,7 @@ find_package(Gflags REQUIRED)
find_package(Glog REQUIRED)
# find boost::* to satisfy the folly dep
-find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
+find_package(Boost REQUIRED COMPONENTS system filesystem regex context
program_options)
include_directories(SYSTEM ${OPENSSL_INCLUDE_DIR})