setup.py detects macos (darwin) and adds -flat_namespace flag. This flag is not compatible with GCC that is used to compile target. This patch patch disables darwin detection Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
15 lines
540 B
Diff
15 lines
540 B
Diff
Support build on MacOS
|
|
This patch should be deleted after resolving https://github.com/pycurl/pycurl/issues/727
|
|
---
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -347,9 +347,6 @@ manually. For other SSL backends please
|
|
if not self.libraries:
|
|
self.libraries.append("curl")
|
|
|
|
- # Add extra compile flag for MacOS X
|
|
- if sys.platform.startswith('darwin'):
|
|
- self.extra_link_args.append("-flat_namespace")
|
|
|
|
# Recognize --avoid-stdio on Unix so that it can be tested
|
|
self.check_avoid_stdio()
|