packages/net/git/patches/400-imapsend_without_curl.patch
Peter Wagner 2edb2e36ec git: update to 2.8.2
Fixes:
 CVE-2016-2315
 CVE-2016-2324

Signed-off-by: Peter Wagner <tripolar@gmx.at>
2016-05-13 12:54:35 +02:00

11 lines
383 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -1096,7 +1096,7 @@ else
endif
curl_check := $(shell (echo 072200; $(CURL_CONFIG) --vernum | sed -e '/^70[BC]/s/^/0/') 2>/dev/null | sort -r | sed -ne 2p)
ifeq "$(curl_check)" "072200"
- USE_CURL_FOR_IMAP_SEND = YesPlease
+# USE_CURL_FOR_IMAP_SEND = YesPlease
endif
ifdef USE_CURL_FOR_IMAP_SEND
BASIC_CFLAGS += -DUSE_CURL_FOR_IMAP_SEND