The automake template does not specify libgobject-2.0.la as _LDADD dependency for glib-compile-resources, leading to the following linker error: .../ld: warning: libgmodule-2.0.so.0, needed by ./.libs/libgio-2.0.so, not found (try using -rpath or -rpath-link) ./.libs/libgio-2.0.so: undefined reference to `g_module_supported' ./.libs/libgio-2.0.so: undefined reference to `g_module_symbol' ./.libs/libgio-2.0.so: undefined reference to `g_module_close' ./.libs/libgio-2.0.so: undefined reference to `g_module_error' ./.libs/libgio-2.0.so: undefined reference to `g_module_open' collect2: error: ld returned 1 exit status This commit introduces a patch to add the missing libtool archive to the list of libraries to link. Due to the update of the .am file, a full autoreconf is required to update configure and Makefile, leading to the following error: error: HAVE_GTK_DOC does not appear in AM_CONDITIONAL Therfore another patch is added to properly fix the conditional when using automake-1.15. Finally extend the copyright year in the Makefile and enable the generic autoreconf fixup to properly build and link glib2. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
10 lines
303 B
Diff
10 lines
303 B
Diff
--- a/gio/Makefile.am
|
|
+++ b/gio/Makefile.am
|
|
@@ -695,6 +695,7 @@ bin_PROGRAMS = gio-querymodules glib-com
|
|
|
|
glib_compile_resources_LDADD = libgio-2.0.la \
|
|
$(top_builddir)/gobject/libgobject-2.0.la \
|
|
+ $(top_builddir)/gmodule/libgmodule-2.0.la \
|
|
$(top_builddir)/glib/libglib-2.0.la \
|
|
$(NULL)
|
|
|