packages/lang/python/python3/patches/015-abort-on-failed-modules.patch
Josef Schlehofer ce769db007
python3: Update to version 3.7.4
- Update setuptools to 40.8.0
- Update pip to 19.0.3
- Refreshed patches
- Removed 4 patches (2 of them was included in 3.7.3 and other two are
included in this release)

Makefile python3:
- Move PKG_MAINTAINER above PKG_LICENSE

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
2019-07-10 10:11:50 +02:00

10 lines
322 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -398,6 +398,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
+ if cross_compiling: sys.exit(1)
if self.failed_on_import:
failed = self.failed_on_import[:]