- Update setuptools to 40.8.0 - Update pip to 19.0.3 - Refreshed patches - Removed 4 patches (2 of them was included in 3.7.3 and other two are included in this release) Makefile python3: - Move PKG_MAINTAINER above PKG_LICENSE Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
13 lines
758 B
Diff
13 lines
758 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -591,8 +591,9 @@ class PyBuildExt(build_ext):
|
|
# directly since an inconsistently reproducible issue comes up where
|
|
# the environment variable is not set even though the value were passed
|
|
# into configure and stored in the Makefile (issue found on OS X 10.3).
|
|
+ rt_lib_dirs = [] if cross_compiling else self.compiler.runtime_library_dirs
|
|
for env_var, arg_name, dir_list in (
|
|
- ('LDFLAGS', '-R', self.compiler.runtime_library_dirs),
|
|
+ ('LDFLAGS', '-R', rt_lib_dirs),
|
|
('LDFLAGS', '-L', self.compiler.library_dirs),
|
|
('CPPFLAGS', '-I', self.compiler.include_dirs)):
|
|
env_val = sysconfig.get_config_var(env_var)
|