- Update setuptools to 40.8.0 - Update pip to 19.0.3 - Refreshed patches - Removed 4 patches (2 of them was included in 3.7.3 and other two are included in this release) Makefile python3: - Move PKG_MAINTAINER above PKG_LICENSE Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
19 lines
788 B
Diff
19 lines
788 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -581,16 +581,9 @@ class PyBuildExt(build_ext):
|
|
os.unlink(tmpfile)
|
|
|
|
def detect_modules(self):
|
|
- # Ensure that /usr/local is always used, but the local build
|
|
- # directories (i.e. '.' and 'Include') must be first. See issue
|
|
- # 10520.
|
|
- if not cross_compiling:
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if cross_compiling:
|
|
self.add_gcc_paths()
|
|
- self.add_multiarch_paths()
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|