bug fixes: - Remove unreachable code path - exit: report if the exit command was killed - exit: fix race zombie reaper - conn_sock: allow watchdog messages through the notify socket proxy - seccomp: add support for seccomp notify misc: - Add seccomp to build dependency included patch removes unnecessary dependency of libdl and also allows a succesfull build disabled for arc where libseccomp does not seem to be available Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
19 lines
575 B
Diff
19 lines
575 B
Diff
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -34,7 +34,6 @@ add_project_arguments('-Os', '-Wall', '-
|
|
language : 'c')
|
|
|
|
glib = dependency('glib-2.0')
|
|
-libdl = cc.find_library('dl')
|
|
|
|
executable('conmon',
|
|
['src/conmon.c',
|
|
@@ -71,7 +70,7 @@ executable('conmon',
|
|
'src/utils.h',
|
|
'src/seccomp_notify.c',
|
|
'src/seccomp_notify.h'],
|
|
- dependencies : [glib, libdl],
|
|
+ dependencies : [glib],
|
|
install : true,
|
|
install_dir : join_paths(get_option('libexecdir'), 'podman'),
|
|
)
|