packages/net/netopeer2/patches/003-BUGFIX-for-missing-eaccess-in-uClibc
Mislav Novakovic 8f2dd7dbb7 sysrepo: update the sysrepo/netopeer2 stack
Patch includes updates to packages:
netopeer2: update to version 0.4.0
sysrepo: update to 0.7.0
libnetconf2: update to 0.9.15
libyang: update to 0.13.46

Signed-off-by: Mislav Novakovic <mislav.novakovic@sartura.hr>
2017-09-18 12:00:38 +02:00

59 lines
2 KiB
Text

Index: netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/CMakeLists.txt
===================================================================
--- netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459.orig/cli/CMakeLists.txt
+++ netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/CMakeLists.txt
@@ -67,6 +67,9 @@ if(NOT MAN_INSTALL_DIR)
set(MAN_INSTALL_DIR share/man)
endif()
+include(CheckFunctionExists)
+check_function_exists(eaccess HAVE_EACCESS)
+
# install binary
install(TARGETS netopeer2-cli DESTINATION ${BIN_INSTALL_DIR})
Index: netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/commands.c
===================================================================
--- netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459.orig/cli/commands.c
+++ netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/commands.c
@@ -37,6 +37,10 @@
# include <openssl/x509v3.h>
#endif
+#ifndef HAVE_EACCESS
+#define eaccess access
+#endif
+
#include "commands.h"
#include "configuration.h"
#include "completion.h"
Index: netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/completion.c
===================================================================
--- netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459.orig/cli/completion.c
+++ netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/completion.c
@@ -27,6 +27,10 @@
#include <nc_client.h>
+#ifndef HAVE_EACCESS
+#define eaccess access
+#endif
+
#include "commands.h"
#include "linenoise/linenoise.h"
Index: netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/configuration.c
===================================================================
--- netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459.orig/cli/configuration.c
+++ netopeer2-0.4.0-d028c1f931819db4b3e3cb1fd2d349a4fd5c0459/cli/configuration.c
@@ -28,6 +28,10 @@
#include <libyang/libyang.h>
#include <nc_client.h>
+#ifndef HAVE_EACCESS
+#define eaccess access
+#endif
+
#include "configuration.h"
#include "commands.h"
#include "linenoise/linenoise.h"