This patch tries to address the following package issues: - the upstream hg repository seems to contain some invalid timestamps, at least the following warning are generated during package compilation (only one example): emcy.c: Timestamp out of range; substituting 2514-05-30 01:53:03.999999999 This can be fixed by touching all files after unpacking, thus tar is now given the -m switch. - one or more LEDE buildbot(s) do not have hg tool installed and thus are not able to checkout the sources from upstream This patch populates PKG_MIRROR_HASH in the hope that the buildbot's first try is to download an already packed source tarball prior to checkout it out from upstream. - While at packaging from upstream, use the common infrastructure, i.e. use a source date etc. This also results in tar.xz files and thus reduces the disk footprint a little bit. - during compilation the follwing warning could be observed: cc1: note: someone does not honour copts correctly, passed 0 times To silent down these warning, patch the Makefiles and pass the expected option. Important note: changes are only compile tested due to missing hardware at hand. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
44 lines
993 B
Diff
44 lines
993 B
Diff
--- a/drivers/can_socket/Makefile.in
|
|
+++ b/drivers/can_socket/Makefile.in
|
|
@@ -23,7 +23,7 @@
|
|
|
|
CC = SUB_CC
|
|
OPT_CFLAGS = -O2
|
|
-CFLAGS = SUB_OPT_CFLAGS
|
|
+CFLAGS = SUB_OPT_CFLAGS -fhonour-copts
|
|
PROG_CFLAGS = SUB_PROG_CFLAGS
|
|
PREFIX = SUB_PREFIX
|
|
TARGET = SUB_TARGET
|
|
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -101,7 +101,7 @@ uninstall:
|
|
rm -rf $(DESTDIR)$(PREFIX)/include/canfestival
|
|
|
|
else
|
|
-CFLAGS = SUB_OPT_CFLAGS
|
|
+CFLAGS = SUB_OPT_CFLAGS -fhonour-copts
|
|
|
|
ifeq ($(TARGET),none)
|
|
canfestival: libcanfestival.o
|
|
--- a/drivers/unix/Makefile.in
|
|
+++ b/drivers/unix/Makefile.in
|
|
@@ -85,7 +85,7 @@ install:
|
|
|
|
|
|
else
|
|
-CFLAGS = SUB_OPT_CFLAGS
|
|
+CFLAGS = SUB_OPT_CFLAGS -fhonour-copts
|
|
|
|
driver: libcanfestival_$(TARGET).a
|
|
|
|
--- a/drivers/timers_unix/Makefile.in
|
|
+++ b/drivers/timers_unix/Makefile.in
|
|
@@ -23,7 +23,7 @@
|
|
|
|
CC = SUB_CC
|
|
OPT_CFLAGS = -O2
|
|
-CFLAGS = SUB_OPT_CFLAGS
|
|
+CFLAGS = SUB_OPT_CFLAGS -fhonour-copts
|
|
PROG_CFLAGS = SUB_PROG_CFLAGS
|
|
OS_NAME = SUB_OS_NAME
|
|
ARCH_NAME = SUB_ARCH_NAME
|