packages/net/ola/patches/200-configure-acx-pthread.patch
Marek Behún 34db95a42e ola: fix compilation of this package
This package does not currently compile.

This is needed to do so that it compiles:
- fix emptying CXX variable in configure script
- fix automake not generating Makefile (remove doxygen definitions)
- force gnu++11 by patch, does not work with configure variable
Also because of changed API in libmicrohttpd:
- fix HttpServer

Moreover this package does not support --disable-slp configure option
anymore, remove it.

Signed-off-by: Marek Behún <kabel@blackhole.sk>
2020-09-24 16:21:20 +02:00

12 lines
437 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -400,8 +400,7 @@ ACX_PTHREAD([
LIBS="$PTHREAD_LIBS $LIBS"
CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
CXXFLAGS="$CXXFLAGS $PTHREAD_CXXFLAGS"
- CC="$PTHREAD_CC"
- CXX="$PTHREAD_CXX"],
+ CC="$PTHREAD_CC"],
[AC_MSG_ERROR([Missing pthread, please install it])])
# pthread_setname_np can take either 1 or 2 arguments.