packages/lang/python/python-txsocksx/patches/002-do-not-use-vcversioner.patch
Alexandru Ardelean 68312f49c0 python packages: move all things python under lang/python
I admit this may be be a bit aggressive, but the lang
folder is getting cluttered/filled up with Python, PHP, Perl,
Ruby, etc. packages.

Makes sense to try to group them into per-lang folders.

I took the Pythons.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
2017-05-17 16:51:14 +03:00

29 lines
678 B
Diff

diff --git a/setup.py b/setup.py
index 7979f89..5e1abb3 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,8 @@
# Copyright (c) Aaron Gallagher <_@habnab.it>
# See COPYING for details.
+import os
+
from setuptools import setup
@@ -30,10 +32,11 @@ setup(
],
license='ISC',
- setup_requires=['vcversioner>=1'],
- vcversioner={
- 'version_module_paths': ['txsocksx/_version.py'],
- },
+ #setup_requires=['vcversioner>=1'],
+ #vcversioner={
+ # 'version_module_paths': ['txsocksx/_version.py'],
+ #},
+ version=os.environ.get('PKG_VERSION'),
install_requires=install_requires,
packages=['txsocksx', 'txsocksx.test'],
)