packages/utils/setools/patches/020-no-deprecated.patch
Ilya Lipnitskiy 5d8d4fbbcb
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset:

  find -L package/feeds/packages/ -name patches | \
  sed 's/patches$/refresh/' | sort | xargs make

Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
2021-02-20 16:02:15 -08:00

10 lines
518 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -125,6 +125,7 @@ ext_py_mods = [Extension('setools.policy
'-Wno-unreachable-code',
'-Wno-implicit-fallthrough',
'-Wno-cast-function-type',
+ '-Wno-deprecated-declarations',
'-fno-exceptions'])]
installed_data = [('share/man/man1', glob.glob("man/*.1"))]