Currently the pc file has includedir hard coded to "/usr/include" and libdir to "/usr/lib". This commit changes this so they can be controlled via the "prefix" variable. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
10 lines
275 B
Diff
10 lines
275 B
Diff
--- a/src/port/Makefile
|
|
+++ b/src/port/Makefile
|
|
@@ -63,6 +63,7 @@ uninstall:
|
|
libpgport.a: $(OBJS)
|
|
rm -f $@
|
|
$(AR) $(AROPT) $@ $^
|
|
+ $(RANLIB) libpgport.a
|
|
|
|
# thread.o and thread_shlib.o need PTHREAD_CFLAGS (but thread_srv.o does not)
|
|
thread.o: CFLAGS+=$(PTHREAD_CFLAGS)
|