packages/utils/setools/patches/020-no-deprecated.patch
Rosen Penev 21f19a4cab setools: fix compilation with python 3.9
Don't warn on deprecated declarations.

Rename warning patch. It's specific to foritfy-headers.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-10-28 22:37:43 -07:00

10 lines
550 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -126,6 +126,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
'-Wno-unreachable-code',
'-Wno-implicit-fallthrough',
'-Wno-cast-function-type',
+ '-Wno-deprecated-declarations',
'-fno-exceptions'])]
installed_data = [('share/man/man1', glob.glob("man/*.1"))]