The libintl check is broken in meson.build. Patched it and added back the gettext build dependencies. Avoids the proxy-intl thing that glib2 likes to use. Updated configure options. Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
512 B
Diff
11 lines
512 B
Diff
--- a/glib/valgrind.h 2019-12-12 14:53:26.000200499 +0100
|
|
+++ b/glib/valgrind.h 2019-12-12 14:49:45.056163300 +0100
|
|
@@ -158,7 +158,7 @@
|
|
# define PLAT_s390x_linux 1
|
|
#elif defined(__linux__) && defined(__mips__) && (__mips==64)
|
|
# define PLAT_mips64_linux 1
|
|
-#elif defined(__linux__) && defined(__mips__) && (__mips!=64)
|
|
+#elif defined(__linux__) && defined(__mips__) && (__mips!=64) && !defined(__mips16)
|
|
# define PLAT_mips32_linux 1
|
|
#elif defined(__sun) && defined(__i386__)
|
|
# define PLAT_x86_solaris 1
|