Switched to CMake. CMake compiles faster. Added libsyn123 library as it's needed since version 1.26. Before: time make package/mpg123/compile -j 12 Executed in 16.05 secs fish external usr time 26.65 secs 0.00 micros 26.65 secs sys time 4.82 secs 833.00 micros 4.81 secs After: time make package/mpg123/compile -j 12 Executed in 12.12 secs fish external usr time 19.35 secs 0.00 micros 19.35 secs sys time 3.22 secs 752.00 micros 3.22 secs Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
356 B
Diff
11 lines
356 B
Diff
--- a/ports/cmake/src/CMakeLists.txt
|
|
+++ b/ports/cmake/src/CMakeLists.txt
|
|
@@ -199,7 +199,7 @@ if(NOT CHECK_MODULES OR NOT COREAUDIO_REQUIRED EQUAL -1)
|
|
endif()
|
|
endif()
|
|
|
|
-find_package(PkgConfig)
|
|
+#find_package(PkgConfig)
|
|
if(PKG_CONFIG_FOUND)
|
|
if(NOT CHECK_MODULES OR NOT PULSE_REQUIRED EQUAL -1)
|
|
pkg_search_module(PULSE libpulse-simple)
|