packages/libs/libpfring/patches/010-fix-buildbots.patch
Rosen Penev 3ea82cd800 libpfring: Fix compilation when missing lex
Buildbots are missing lex, which is normally a symlink to flex. This
solution is used elsewhere in the package but missing here.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2018-11-13 13:41:47 -08:00

10 lines
307 B
Diff

diff --git a/userland/nbpf/Makefile.in b/userland/nbpf/Makefile.in
index b0d8181..8221e41 100644
--- a/userland/nbpf/Makefile.in
+++ b/userland/nbpf/Makefile.in
@@ -1,4 +1,4 @@
-LEX = lex
+LEX = flex
YACC = bison
INCLUDE = -I../lib -I../../kernel
LIBS=`../lib/pfring_config --libs` -lpthread #@NDPI_LIB@