packages/net/unbound/patches/010-configure-uname.patch
Eric Luehrsen 6bc0293a73 unbound: update to 1.17.0
Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
2022-11-21 18:58:11 +08:00

14 lines
438 B
Diff

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -818,7 +818,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi