packages/net/cshark/Makefile
Paul Fertser 0c10c224be treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
  make package/$i/download
done

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-04-21 22:46:58 +02:00

53 lines
1.2 KiB
Makefile

#
# Copyright (C) 2014-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=cshark
PKG_SOURCE_DATE:=2020-07-22
PKG_SOURCE_VERSION:=c0d32fb6df3cd095fecac8aefe8d188170246403
PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/cloudshark/cshark.git
PKG_MIRROR_HASH:=35fd177653725e64c330fca62e674c1106d5893c8a33bad29b8e6dac4a4d4dcc
PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
PKG_LICENSE:=BSD-2-Clause
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/cshark
SECTION:=net
CATEGORY:=Network
TITLE:=CloudShark capture tool
URL:=https://cloudshark.io/
DEPENDS:=+libjson-c +libpcap +libuci +libubox +libuclient +libustream-mbedtls
endef
CMAKE_OPTIONS += \
-DWITH_DEBUG=OFF
define Package/cshark/conffiles
/etc/config/cshark
endef
define Package/cshark/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) \
$(PKG_INSTALL_DIR)/usr/bin/cshark \
$(1)/sbin/
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_CONF) \
$(PKG_BUILD_DIR)/config/cshark \
$(1)/etc/config/
endef
$(eval $(call BuildPackage,cshark))