packages/utils/hwinfo/patches/010-hardcoding-version.patch
Rosen Penev 6af7fbbf01 hwinfo: fix compilation with ARC
Added a small patch to fix compilation.

Renamed patch files to have a .patch suffix. Makes them easier to read
with vim and probably IDEs.

Remove UCLIBC depend since it's no longer present.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-05-29 01:19:26 -07:00

19 lines
735 B
Diff

hardcode version of hwinfo, this must be changed in sync
with hwinfo version changes when updating the package
--- a/Makefile
+++ b/Makefile
@@ -12,12 +12,8 @@ export SO_LIBS
GIT2LOG := $(shell if [ -x ./git2log ] ; then echo ./git2log --update ; else echo true ; fi)
GITDEPS := $(shell [ -d .git ] && echo .git/HEAD .git/refs/heads .git/refs/tags)
-BRANCH := $(shell [ -d .git ] && git branch | perl -ne 'print $$_ if s/^\*\s*//')
-ifdef HWINFO_VERSION
-VERSION := $(shell echo ${HWINFO_VERSION} > VERSION; cat VERSION)
-else
-VERSION := $(shell $(GIT2LOG) --version VERSION ; cat VERSION)
-endif
+BRANCH := master
+VERSION := $(shell echo 21.71 > VERSION; cat VERSION)
PREFIX := hwinfo-$(VERSION)
include Makefile.common