Update collectd to version 5.9.0 * remove backported upstream patches (sensors, modbus) * remove lua patch that has been been implemented upstream (See collectd PR 3144) * refresh patches and accommodate into upstream path changes * place the 'stations' datatype for iwinfo in alpbetically correct place in types.db * add libmnl dependency to 'processes' plugin required for the new Linux process Delay Accounting capability. (Alternatively the capability & requirement might be patched away in Makefile.am, HAVE_LIBTASKSTATS from collectd_4ea7a572) * new plugins (disabled): ampq1, gpu_nvidia, pcie_errors, write_stackdriver, write_syslog compile-tested: ar71xx/WNDR3700 (all plugins) run-tested: ar71xx/WNDR3700 (selected plugins) Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
11 lines
252 B
Diff
11 lines
252 B
Diff
--- a/src/olsrd.c
|
|
+++ b/src/olsrd.c
|
|
@@ -582,7 +582,7 @@ static int olsrd_read(void) /* {{{ */
|
|
if (fh == NULL)
|
|
return -1;
|
|
|
|
- fputs("\r\n", fh);
|
|
+ fputs("/all \r\n", fh);
|
|
fflush(fh);
|
|
|
|
while (fgets(buffer, sizeof(buffer), fh) != NULL) {
|