From the Tor project page: obfsproxy is a tool that attempts to circumvent censorship, by transforming the Tor traffic between the client and the bridge. This way, censors, who usually monitor traffic between the client and the bridge, will see innocent-looking transformed traffic instead of the actual Tor traffic. This depends on: - pyptlib (#2053) - twisted (#2052) Also, txsocksx (#2058) is necessary to use an outgoing SOCKS proxy, and having either gmpy2 (#2067) or gmpy (#2051) installed will help speed up calculations. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
16 lines
368 B
Diff
16 lines
368 B
Diff
diff --git a/setup.py b/setup.py
|
|
index 2353a29..8d3d56d 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -27,6 +27,11 @@ setup(
|
|
'obfsproxy = obfsproxy.pyobfsproxy:run'
|
|
]
|
|
},
|
|
+ options = {
|
|
+ 'build_scripts': {
|
|
+ 'executable': '/usr/bin/python'
|
|
+ },
|
|
+ },
|
|
|
|
install_requires = [
|
|
'setuptools',
|