According to PEP394 (http://legacy.python.org/dev/peps/pep-0394/) the 'python' command should refer to 'python2'. In our case, this means we should reboot the old python package. We could rename the package name to python2, but that would just complicate things a bit with other packages, and since we're doing this reboot, such a complication would be unnecessary. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
11 lines
522 B
Diff
11 lines
522 B
Diff
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -410,7 +410,7 @@ platform: $(BUILDPYTHON)
|
|
# Build the shared modules
|
|
sharedmods: $(BUILDPYTHON)
|
|
@case $$MAKEFLAGS in \
|
|
- *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
|
|
+ *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
|
|
*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
|
|
esac
|
|
|