packages/net/miniupnpd/patches/200-remove-default-cflags.patch
Rosen Penev 96f50729ad
miniupnpd: Update to 2.1.20190408
Refreshed patch.

Added PKG_LICENSE_FILES.

Added --as-needed linker flag for slightly smaller size.

Removed -O2 hack to get it to compile. As part of this, removed a bunch of
CFLAGS that are normally passed which potentially affect compilation with
Os.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-04-13 17:04:23 -07:00

27 lines
826 B
Diff

--- a/Makefile.linux
+++ b/Makefile.linux
@@ -23,16 +23,16 @@
#
#CFLAGS = -O -g -DDEBUG
CFLAGS ?= -Os
-CFLAGS += -fno-strict-aliasing
-CFLAGS += -fno-common
-CFLAGS += -fstack-protector -fPIE
-CFLAGS += -D_FORTIFY_SOURCE=2
-CPPFLAGS += -D_GNU_SOURCE
-CFLAGS += -Wall
-CFLAGS += -Wextra -Wstrict-prototypes -Wdeclaration-after-statement
+#CFLAGS += -fno-strict-aliasing
+#CFLAGS += -fno-common
+#CFLAGS += -fstack-protector -fPIE
+#CFLAGS += -D_FORTIFY_SOURCE=2
+#CPPFLAGS += -D_GNU_SOURCE
+#CFLAGS += -Wall
+#CFLAGS += -Wextra -Wstrict-prototypes -Wdeclaration-after-statement
#CFLAGS += -Wno-missing-field-initializers
#CFLAGS += -ansi # iptables headers does use typeof which is a gcc extension
-LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie
+LDFLAGS ?= -Wl,-z,now -Wl,-z,relro -pie
CC ?= gcc
RM = rm -f
INSTALL = install