Neither the configure option nor configure variable to disable linking against PCRE seem to work anymore, so simply drop both and add a dependency on libpcre. As net-snmp is unlikely to fit on devices with small flash anyway, the extra size requirement shouldn't be a problem. If it is, feel free to submit a patch to fix the broken upstream behaviour. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
11 lines
503 B
Diff
11 lines
503 B
Diff
--- a/Makefile.top
|
|
+++ b/Makefile.top
|
|
@@ -87,7 +87,7 @@ LIBCURRENT = 40
|
|
LIBAGE = 0
|
|
LIBREVISION = 0
|
|
|
|
-LIB_LD_CMD = $(LIBTOOL) --mode=link $(LINKCC) $(CFLAGS) -rpath $(libdir) -version-info $(LIBCURRENT):$(LIBREVISION):$(LIBAGE) -o
|
|
+LIB_LD_CMD = $(LIBTOOL) --mode=link $(LINKCC) $(CFLAGS) -rpath $(libdir) $(LDFLAGS) -version-info $(LIBCURRENT):$(LIBREVISION):$(LIBAGE) -o
|
|
LIB_EXTENSION = la
|
|
LIB_VERSION =
|
|
LIB_LDCONFIG_CMD = $(LIBTOOL) --mode=finish $(INSTALL_PREFIX)$(libdir)
|