Includes fixes for: * Windows builds updated to bzip2 1.0.8 to mitigate CVE-2016-3189 and CVE-2019-12900 * CVE-2022-26488: Escalation of privilege via Windows Installer Signed-off-by: Jeffery To <jeffery.to@gmail.com>
22 lines
845 B
Diff
22 lines
845 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -15616,7 +15616,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
|
$as_echo "$ABIFLAGS" >&6; }
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
|
$as_echo_n "checking SOABI... " >&6; }
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SOABI" >&5
|
|
$as_echo "$SOABI" >&6; }
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4824,7 +4824,7 @@ AC_SUBST(SOABI)
|
|
AC_MSG_CHECKING(ABIFLAGS)
|
|
AC_MSG_RESULT($ABIFLAGS)
|
|
AC_MSG_CHECKING(SOABI)
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
AC_MSG_RESULT($SOABI)
|
|
|
|
# Release and debug (Py_DEBUG) ABI are compatible, but not Py_TRACE_REFS ABI
|