This removes Python build variants and adds PYTHON3_PKG_BUILD:=0 (where appropriate) for the Seafile packages. This also updates the way the Python bindings packages are packaged, using automake installation instead of manual install recipes. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
14 lines
412 B
Diff
14 lines
412 B
Diff
--- a/python/seafile/Makefile.am
|
|
+++ b/python/seafile/Makefile.am
|
|
@@ -1,3 +1,3 @@
|
|
seafiledir=${pyexecdir}/seafile
|
|
|
|
-seafile_PYTHON = __init__.py rpcclient.py
|
|
+seafile_DATA = __init__.py rpcclient.py
|
|
--- a/python/seaserv/Makefile.am
|
|
+++ b/python/seaserv/Makefile.am
|
|
@@ -1,3 +1,3 @@
|
|
seaservdir=${pyexecdir}/seaserv
|
|
|
|
-seaserv_PYTHON = __init__.py service.py api.py
|
|
+seaserv_DATA = __init__.py service.py api.py
|