packages/net/seafile-server/patches/012-automake-no-python-compile.patch
Jeffery To 81e99fa7ff seafile: Remove Python variants, update Python packaging
This removes Python build variants and adds PYTHON3_PKG_BUILD:=0 (where
appropriate) for the Seafile packages.

This also updates the way the Python bindings packages are packaged,
using automake installation instead of manual install recipes.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2020-04-19 01:56:23 +08:00

14 lines
412 B
Diff

--- a/python/seafile/Makefile.am
+++ b/python/seafile/Makefile.am
@@ -1,3 +1,3 @@
seafiledir=${pyexecdir}/seafile
-seafile_PYTHON = __init__.py rpcclient.py
+seafile_DATA = __init__.py rpcclient.py
--- a/python/seaserv/Makefile.am
+++ b/python/seaserv/Makefile.am
@@ -1,3 +1,3 @@
seaservdir=${pyexecdir}/seaserv
-seaserv_PYTHON = __init__.py service.py api.py
+seaserv_DATA = __init__.py service.py api.py