34 lines
1,010 B
Diff
34 lines
1,010 B
Diff
From 9a260723b615dc2e5c6c72767656f9397f59eecf Mon Sep 17 00:00:00 2001
|
|
From: Natanael Copa <ncopa@alpinelinux.org>
|
|
Date: Thu, 5 Nov 2015 13:19:20 +0000
|
|
Subject: [PATCH] open-vm-tools: Add --disable-werror configure option
|
|
|
|
Packagers will normally not want the -Werror compile option as it may
|
|
break compilation depending on the platform specific warnings.
|
|
|
|
Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
|
|
---
|
|
configure.ac | 12 +++++++++++-
|
|
1 file changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1461,7 +1461,17 @@ AC_C_VOLATILE
|
|
|
|
### General flags / actions
|
|
CFLAGS="$CFLAGS -Wall"
|
|
-CFLAGS="$CFLAGS -Werror"
|
|
+AC_ARG_ENABLE(
|
|
+ werror,
|
|
+ AS_HELP_STRING(
|
|
+ [--disable-werror],
|
|
+ [disable compilation with -Werror]),
|
|
+ [enable_werror="$enableval"],
|
|
+ [enable_werror="yes"])
|
|
+
|
|
+if test "$enable_werror" = "yes"; then
|
|
+ CFLAGS="$CFLAGS -Werror"
|
|
+fi
|
|
|
|
# -Wno-unknown-pragmas is due to gcc not understanding '#pragma ident'
|
|
# in Xlib.h on OpenSolaris.
|