packages/libs/libre2/patches/010-cxx17.patch
Rosen Penev 57b2623d8b
re2: update to 2020-04-01
Massive cleanup of Makefile.

Remove inactive maintainer.

Remove completely unused host build.

Shorten title so that it shows under menuconfig.

Remove pointless static/shared choice.

Add C++17 patch as libcxx seems to need it with this package.

Add ABI_VERSION.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-04-14 16:19:18 -07:00

23 lines
728 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,9 +38,9 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
add_compile_options(/utf-8)
elseif(CYGWIN OR MINGW)
# See https://stackoverflow.com/questions/38139631 for details.
- add_compile_options(-std=gnu++11)
+ add_compile_options(-std=gnu++17)
elseif(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
- add_compile_options(-std=c++11)
+ add_compile_options(-std=c++17)
endif()
if(WIN32)
--- a/re2.pc
+++ b/re2.pc
@@ -6,5 +6,5 @@ libdir=@libdir@
Name: re2
Description: RE2 is a fast, safe, thread-friendly regular expression engine.
Version: 0.0.0
-Cflags: -std=c++11 -pthread -I${includedir}
+Cflags: -std=c++17 -pthread -I${includedir}
Libs: -pthread -L${libdir} -lre2