python2 library is now removed as the transition has been done by the upstream project OVN is now a separate project released with its own release plan and it's not included within openvswitch starting with ovs 2.13. openvswitch.mk is split out from the main Makefile for adding ovn packages back in following commits. The following two patches are already included in 2.13 - ovsdb-idlc-fix-dict-change-during-iteration.patch - compat-Include-confirm_neigh-parameter-if-needed.patch Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From c17f9e73b543043b438dee6759ae20047ee33d4a Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Fri, 20 Mar 2020 15:11:31 +0800
|
|
Subject: [PATCH] python: separate host/target python for cross-compile
|
|
|
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|
---
|
|
Makefile.am | 2 +-
|
|
m4/openvswitch.m4 | 1 +
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index b279303d1..6140b2c7f 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -60,7 +60,7 @@ endif
|
|
# foo/__init__.pyc will cause Python to ignore foo.py.
|
|
run_python = \
|
|
PYTHONPATH=$(top_srcdir)/python$(psep)$$PYTHONPATH \
|
|
- PYTHONDONTWRITEBYTECODE=yes $(PYTHON3)
|
|
+ PYTHONDONTWRITEBYTECODE=yes $(PYTHON3_HOST)
|
|
|
|
ALL_LOCAL =
|
|
BUILT_SOURCES =
|
|
diff --git a/m4/openvswitch.m4 b/m4/openvswitch.m4
|
|
index add3aabcc..839eb7bda 100644
|
|
--- a/m4/openvswitch.m4
|
|
+++ b/m4/openvswitch.m4
|
|
@@ -383,6 +383,8 @@ else:
|
|
AC_MSG_ERROR([Python 3.4 or later is required but not found in $PATH, please install it or set $PYTHON3 to point to it])
|
|
fi
|
|
AC_ARG_VAR([PYTHON3])
|
|
+ PYTHON3_HOST=$ovs_cv_python3_host
|
|
+ AM_MISSING_PROG([PYTHON3_HOST], [python3])
|
|
PYTHON3=$ovs_cv_python3])
|
|
|
|
dnl Checks for flake8.
|