packages/libs/nss/patches/002-os_test.patch
Lucian Cristian b75c860fac nss: add nss-tools
Network Security Services (NSS) is a set of libraries designed
to support cross-platform development of security-enabled client
and server applications. Applications built with NSS can support
SSL v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME,
X.509 v3 certificates, and other security standards.

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
2019-04-06 21:22:46 +03:00

18 lines
486 B
Diff

--- a/nss/coreconf/arch.mk 2019-04-01 22:20:32.470080052 +0300
+++ b/nss/coreconf/arch.mk 2019-04-01 22:21:01.730987548 +0300
@@ -20,13 +20,13 @@
# Macros for getting the OS architecture
#
-OS_ARCH := $(subst /,_,$(shell uname -s))
+OS_ARCH ?= $(subst /,_,$(shell uname -s))
#
# Attempt to differentiate between sparc and x86 Solaris
#
-OS_TEST := $(shell uname -m)
+OS_TEST ?= $(shell uname -m)
ifeq ($(OS_TEST),i86pc)
OS_RELEASE := $(shell uname -r)_$(OS_TEST)
else