python2 library is now removed as the transition has been done by the upstream project OVN is now a separate project released with its own release plan and it's not included within openvswitch starting with ovs 2.13. openvswitch.mk is split out from the main Makefile for adding ovn packages back in following commits. The following two patches are already included in 2.13 - ovsdb-idlc-fix-dict-change-during-iteration.patch - compat-Include-confirm_neigh-parameter-if-needed.patch Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
From cb16c9b1be1a0d11a26a3027af8168bd314c4114 Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Mon, 16 Mar 2020 15:18:16 +0800
|
|
Subject: [PATCH] datapath: unexport LDFLAGS
|
|
|
|
OpenWrt build system will put "-specs=.../hardened-pie-ld.specs" into
|
|
LDFLAGS when building PIE binaries. However the "-specs" argument is
|
|
inteneded for "gcc" the driver while "ld" the linker when presented will
|
|
complain it as unrecognized error.
|
|
|
|
This can cause Kbuild error when building datapath kernel modules. The
|
|
issue should only happen when compiling against upstream kernel 4.14 and
|
|
earlier. Later ones should have been fixed with kernel upstream commit
|
|
d503ac531a5 ("kbuild: rename LDFLAGS to KBUILD_LDFLAGS")
|
|
|
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|
---
|
|
datapath/linux/Makefile.in | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/datapath/linux/Makefile.in b/datapath/linux/Makefile.in
|
|
index efc1663e4..61fcaa67e 100644
|
|
--- a/datapath/linux/Makefile.in
|
|
+++ b/datapath/linux/Makefile.in
|
|
@@ -1,5 +1,6 @@
|
|
ifeq ($(KERNELRELEASE),)
|
|
# We're being called directly by running make in this directory.
|
|
+unexport LDFLAGS
|
|
include Makefile.main
|
|
else
|
|
# We're being included by the Linux kernel build system
|