This adds the crtmpserver package from the old svn package tree. I adopt the licensing information and will maintain the package in the future. I also updated the package to the latest version and ensure that is building on x86_64, ar71xx and avr32. Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
13 lines
621 B
Diff
13 lines
621 B
Diff
--- a/builders/make/linux.mk
|
|
+++ b/builders/make/linux.mk
|
|
@@ -31,8 +31,8 @@ OPTIMIZATIONS = -O3
|
|
COMPILE_FLAGS = $(FPIC) $(OPTIMIZATIONS) $(CFLAGS)
|
|
|
|
#linking flags
|
|
-dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,"\$$ORIGIN"
|
|
-dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,"\$$ORIGIN"
|
|
+dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,/usr/lib/crtmpserver
|
|
+dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,/usr/lib/crtmpserver
|
|
|
|
#compile switches
|
|
PLATFORM_DEFINES = \
|