packages/utils/hwinfo/patches/0-hardcoding-version
Alberto Bursi 509b9d52a0 hwinfo: add new package
add hwinfo package, it is a complete
system hardware detection tool,
similar to lshw but is written in C
and has minimal dependencies.
It is part of core SUSE Linux
applications like Yast installer
and system configurator tool so
it's regularly maintained.

Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com>
2020-06-01 19:35:42 +02:00

19 lines
721 B
Text

hardcode version of hwinfo, this must be changed in sync
with hwinfo version changes when updating the package
--- a/Makefile
+++ b/Makefile
@@ -12,12 +12,8 @@
GIT2LOG := $(shell if [ -x ./git2log ] ; then echo ./git2log --update ; else echo true ; fi)
GITDEPS := $(shell [ -d .git ] && echo .git/HEAD .git/refs/heads .git/refs/tags)
-BRANCH := $(shell [ -d .git ] && git branch | perl -ne 'print $$_ if s/^\*\s*//')
-ifdef HWINFO_VERSION
-VERSION := $(shell echo ${HWINFO_VERSION} > VERSION; cat VERSION)
-else
-VERSION := $(shell $(GIT2LOG) --version VERSION ; cat VERSION)
-endif
+BRANCH := master
+VERSION := $(shell echo 21.7 > VERSION; cat VERSION)
PREFIX := hwinfo-$(VERSION)
include Makefile.common