packages/lang/python/python-cryptodomex/patches/002-omit-tests.patch
Richard Yu f0869d663c
python-cryptodome: update to 3.8.1
Signed-off-by: Richard Yu <yurichard3839@gmail.com>
2019-04-08 18:55:27 +08:00

12 lines
324 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -293,6 +293,9 @@ package_data = {
],
}
+packages = [i for i in packages if not i.startswith('Crypto.SelfTest')]
+package_data = {k: v for k, v in package_data.items() if not k.startswith('Crypto.SelfTest')}
+
ext_modules = [
# Hash functions
Extension("Crypto.Hash._MD2",