This is the irssi-abi-8 branch that was not merged back to master but is necessary for compilation. As it touches a submodule, I can't add a patch for it. But I can backport all of the master commits. Get rid of quasselc dependency as it's now a submodule. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
384 B
Diff
11 lines
384 B
Diff
--- a/core/Makefile
|
|
+++ b/core/Makefile
|
|
@@ -24,7 +24,7 @@ ifndef SYSTEM_QUASSELC
|
|
QUASSELC_FLAGS:=-Ilib
|
|
else
|
|
QUASSELC_FLAGS:=$(shell pkg-config --cflags quasselc)
|
|
- LDFLAGS += -lquasselc
|
|
+ LDFLAGS += $(shell pkg-config --libs quasselc)
|
|
endif
|
|
|
|
CFLAGS+=-std=gnu11 -Wall -Wextra -Werror -g $(IRSSI_CFLAGS) $(QUASSELC_FLAGS) -Wmissing-prototypes -Wmissing-declarations
|