This is the irssi-abi-8 branch that was not merged back to master but is necessary for compilation. As it touches a submodule, I can't add a patch for it. But I can backport all of the master commits. Get rid of quasselc dependency as it's now a submodule. Signed-off-by: Rosen Penev <rosenp@gmail.com>
20 lines
692 B
Diff
20 lines
692 B
Diff
--- a/core/Makefile
|
|
+++ b/core/Makefile
|
|
@@ -3,7 +3,7 @@ DESTDIR ?=
|
|
LIBDIR ?= /usr/lib
|
|
|
|
#IRSSI_INCLUDE:=/home/phh/irssi-0.8.16-rc1.phh/
|
|
-IRSSI_INCLUDE:=/usr/include/irssi/
|
|
+IRSSI_INCLUDE?=/usr/include/irssi/
|
|
IRSSI_LIB?=$(DESTDIR)/$(LIBDIR)/irssi
|
|
IRSSI_CFLAGS+=-I$(IRSSI_INCLUDE)/src/
|
|
IRSSI_CFLAGS+=-I$(IRSSI_INCLUDE)/src/core/
|
|
@@ -27,7 +27,7 @@ else
|
|
LDFLAGS += -lquasselc
|
|
endif
|
|
|
|
-CFLAGS=-std=gnu11 -Wall -Wextra -Werror -g -O2 $(IRSSI_CFLAGS) $(QUASSELC_FLAGS) -Wmissing-prototypes -Wmissing-declarations
|
|
+CFLAGS+=-std=gnu11 -Wall -Wextra -Werror -g $(IRSSI_CFLAGS) $(QUASSELC_FLAGS) -Wmissing-prototypes -Wmissing-declarations
|
|
|
|
CFLAGS += $(SSL_CFLAGS)
|
|
LDFLAGS+= $(SSL_LDLAGS)
|