Refreshed Python patches. Updated pip & setuptools version. For pip, patch '001-pep517-pyc-fix.patch' was reworked. Also, the current version of the bundled pip (21.1.1) no longer supports Python2, so the 'py2.py3' suffix gets replaced with just py3. For setuptools, there is no longer a script/module: https://github.com/pypa/setuptools/pull/2544 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
11 lines
421 B
Diff
11 lines
421 B
Diff
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1607,7 +1607,7 @@ python-config: $(srcdir)/Misc/python-con
|
|
@ # On Darwin, always use the python version of the script, the shell
|
|
@ # version doesn't use the compiler customizations that are provided
|
|
@ # in python (_osx_support.py).
|
|
- @if test `uname -s` = Darwin; then \
|
|
+ @if test "$(USE_PYTHON_CONFIG_PY)" = 1; then \
|
|
cp python-config.py python-config; \
|
|
fi
|
|
|