GNUnet has not been updated for a while due to the gnurl-situation. Now that we got libcurl-gnutls, we can update GNUnet. For details, please see the GNUnet release notes: https://www.gnunet.org/en/news/2022-09-0.17.6.html https://www.gnunet.org/en/news/2022-10-0.18.0.html https://www.gnunet.org/en/news/2022-11-0.18.1.html https://www.gnunet.org/en/news/2022-12-0.19.0.html https://www.gnunet.org/en/news/2022-12-0.19.1.html https://www.gnunet.org/en/news/2023-01-0.19.2.html Signed-off-by: Daniel Golle <daniel@makrotopia.org>
16 lines
587 B
Diff
16 lines
587 B
Diff
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -727,12 +727,7 @@ LIBCURL_CHECK_CONFIG([], [7.34.0], [],
|
|
|
|
OLD_LIBS=$LIBS
|
|
LIBS="$LIBS $LIBCURL"
|
|
-AC_RUN_IFELSE(
|
|
- [AC_LANG_PROGRAM([[#include <curl/curl.h>]],
|
|
- [[return (CURLSSLSET_OK != curl_global_sslset(CURLSSLBACKEND_GNUTLS, NULL, NULL));]])],
|
|
- [curl_gnutls=1],
|
|
- [AC_MSG_WARN([cURL does not have GnuTLS backend])
|
|
- curl_gnutls=0])
|
|
+curl_gnutls=1
|
|
LIBS=$OLD_LIBS
|
|
AM_CONDITIONAL([HAVE_GNUTLS_CURL], [test "x$curl_gnutls" = "x1"])
|
|
AC_SUBST([curl_gnutls])
|