packages/multimedia/tvheadend/patches/020-strncpy-issue.patch
Rosen Penev 9eea417e92
tvheadend: Fix compilation on GCC8
New string warnings were introduced. Adding -Wno-error to TARGET_CFLAGS
does not work so patch it out.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-05-01 10:12:23 -07:00

13 lines
460 B
Diff

diff --git a/Makefile b/Makefile
index 8c5e380..baef144 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ PROG := $(BUILDDIR)/tvheadend
#
CFLAGS += -g -O2 -Wunused-result
-CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations
+#CFLAGS += -Wall -Werror -Wwrite-strings -Wno-deprecated-declarations
CFLAGS += -Wmissing-prototypes
CFLAGS += -fms-extensions -funsigned-char -fno-strict-aliasing
CFLAGS += -D_FILE_OFFSET_BITS=64