packages/libs/libupm/patches/001-version.patch
John Crispin 221c1e3d03 libupm: add package
upm is a sensor library that sits ontop of libmraa. it has support for a large
number of sensors and exports bindings for node, python, ...

Signed-off-by: John Crispin <blogic@openwrt.org>
2015-10-19 12:20:11 +02:00

16 lines
450 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,12 +26,7 @@
include(GNUInstallDirs)
# Make a version file containing the current version from git.
-include (GetGitRevisionDescription)
-git_describe (VERSION "--tags")
-if ("x_${VERSION}" STREQUAL "x_GIT-NOTFOUND")
- message (WARNING " - Install git to compile a production UPM!")
- set (VERSION "v0.4.0-dirty")
-endif ()
+set (VERSION "v0.4.0")
message (INFO " - UPM Version ${VERSION}")