This was a bit overdue. I did not know about this methodology. Reduces patch fuzz. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
12 lines
603 B
Diff
12 lines
603 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -497,7 +497,8 @@ class PyBuildExt(build_ext):
|
|
add_dir_to_list(dir_list, directory)
|
|
|
|
if os.path.normpath(sys.prefix) != '/usr' \
|
|
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
|
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
|
|
+ and not cross_compiling:
|
|
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
|
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
|
# building a framework with different architectures than
|