packages/net/unbound/patches/010-configure-uname.patch
Eric Luehrsen 824aa45133 unbound: update to 1.14.0
Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
2021-12-10 10:50:14 +01:00

14 lines
438 B
Diff

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -777,7 +777,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi